IDaaS /IIDaaS - issues with Email OTP in US and SMS OTP issues all regions (AWS issues in US Region)

Incident Report for Entrust IDaaS Status Page

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 09:15 UTC

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 06:30 UTC
This incident affected: IDaaS/IIDaaS - United States (*.us.trustedauth.com) (MFA, SMS OTP Delivery (3rd party)), IDaaS/IIDaaS - Germany (*.de.trustedauth.com) (SMS OTP Delivery (3rd party)), IDaaS/IIDaaS - Ireland (*.ie.trustedauth.com) (SMS OTP Delivery (3rd party)), and IDaaS/IIDaaS - Brazil (*.br.trustedauth.com) (SMS OTP Delivery (3rd party)).