Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2026 - 21:00 UTC
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Mar 11, 2026 - 17:21 UTC
This scheduled maintenance affected: IDaaS/IIDaaS - United States (*.us.trustedauth.com) (US - api-directory-sync (Directory Synchronization requests from the ESG), US - api-mobile (Communication with the Entrust Identity mobile app), US - api-password (Directory password service – supports password authentication requests), US - api-radius (RADIUS authentication requests sent from ESG), US - api-saml-oidc (SAML and OIDC requests from SAML/OIDC service providers), US - api-web-management (Administration & UI requests), US - SSL (Client authenticated SSL requests), US - 3rd Party SMS OTP Delivery).