Intermittent errors in US Region due to AWS US issues

Incident Report for Entrust IDaaS Status Page

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:07 UTC

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 16:43 UTC
This incident affected: IDaaS/IIDaaS - United States (*.us.trustedauth.com) (Administration, Single Sign On, MFA, APIs, Gateway Services, Certificate Services, SMS OTP Delivery (3rd party)).